Author: Mats Halfvares, the Content Studio development team.

Published: 2008-09-18

Applies to:
  • Content Studio ver. 5.0 and 5.1 on Vista/Server 2008 with User Account Control is enabled

Type: Information


Symptoms

You receive the error message "Failed to connect to an IPC port. Access is denied" when you try to access a Content Studio web site.

Cause

Content Studio clients (such as a Content Studio Web site) can use two different channels when it communicates with the underlying Content Studio server. The two channels are IPC (Inter process communication) and TCP. IPC is implemented as a named pipe object in the underlying operating system whereas the TCP channel uses regular calls via the TCP protocol. 

If Windows User Account control (UAC) is activated you might not be able to use the IPC protocol with Content Studio. This problem is caused by UAC which can deny access to the underlying named pipe kernel object if the calling process in started with low integrity level.

Resolution

As far as we know this problem is by design and only occurs when navigating to a local web site using Windows Integrated authentication and Internet Explorer. UAC is enabled by default in Windows Vista and Windows Server 2008. You can either turn off UAC or use the TCP protocol instead. Turning off UAC is a very bad idea since it is a very strong protection against attacks from bad software trying to install itself without you knowing it.

It is a better idea to change the protocol used by Content Studio from IPC to TCP. For more information on how to change the communication protocol in Content Studio see the knowledebase article How to change the communication protocol.

Status

This problem has been fixed in Content Studio version 5.2 where the underlying named pipe now has the integrity level lowered to be able to accept calls from low integrity processes.